Site10 Invalid Certificate

Incident Report for DATABASICS Inc

Postmortem

The SSL error was triggered by a cached reference to an expired certificate on one of our load balancers. Clearing the load balancer cache successfully resolved the issue.

Posted May 05, 2025 - 08:10 EDT

Resolved

This incident has been resolved.
Posted May 04, 2025 - 20:21 EDT

Monitoring

The fix got implemented.
Posted May 04, 2025 - 20:21 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 04, 2025 - 20:12 EDT

Investigating

We are currently experiencing an issue related to the SSL certificate for Site 10 Only. As a result, access to the site may be temporarily affected.

Our technical team is actively working to resolve the problem and restore full functionality as quickly as possible. We appreciate your patience and understanding during this time.

We will provide updates as soon as the issue is resolved.
Posted May 04, 2025 - 20:11 EDT
This incident affected: DATABASICS Time and Expense Website And Mobile App.