Temporary Performance Delays – Newark (EWR) Region

Incident Report for DATABASICS Inc

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 06:23 EST

Monitoring

Status Update as of 02/26/2026 from Cloudflare Support

“Our engineering team deployed a significant infrastructure update on February 25th to address the root cause of the elevated latency you've been experiencing. This update optimizes how our edge network handles certain security rules, reducing load on critical infrastructure components in the EWR datacenter.

We are actively monitoring the effectiveness of this fix. Early indicators show improvement, though we continue to observe some elevated latency during US peak traffic hours. Our team is closely tracking these metrics and stands ready to make additional adjustments if needed.”
We will provide updates via our status page: https://www.cloudflarestatus.com/incidents/391rky29892m
Posted Feb 26, 2026 - 07:32 EST

Investigating

Cloudflare has reported increased HTTP request latency originating from the Newark (EWR) datacenter. As a result, users whose traffic is routed through this location may experience:
• Slower page load times
• Intermittent delays when submitting transactions
• Temporary performance degradation
The issue is strictly related to network latency within Cloudflare’s Newark (EWR) facility when traffic is routed through Newark.
Posted Feb 25, 2026 - 14:50 EST
This incident affected: DATABASICS Time and Expense Website And Mobile App.