Our investigation determined that outbound traffic from our internal network was successfully reaching Cloudflare; however, once the traffic entered Cloudflare’s network, the connections began to timeout. This behavior indicated that the issue originated beyond DATABASICS’ internal systems.
We escalated this matter to Cloudflare and passed along the information. A fix was implemented by Cloudflare at 9:40 am Eastern after which application performance was fully restored. Cloudflare drained a network route from their configuration which resolved the timeout issue.
Posted Mar 07, 2026 - 08:09 EST
Monitoring
Error levels have now returned to normal, and you should be able to access the application without further interruption. We are monitoring to ensure traffic remains stable
Posted Mar 06, 2026 - 10:12 EST
Update
We have provided Cloudflare with all the requested data for their investigation. Their engineering team is currently reviewing the information. At this time, we are seeing users access the sites normally without issues. However, there are occasional instances where a request times out and a Cloudflare popup message appears. These events appear to be intermittent and related to the previously reported latency originating from some Cloudflare data centers.
Posted Mar 06, 2026 - 08:37 EST
Update
Additional data got sent to Cloudflare and they are checking.
Posted Mar 06, 2026 - 08:04 EST
Update
Cloudflare is investigating the issue, we collected the data and provided to Cloudflare team and they are checking.
Posted Mar 06, 2026 - 07:48 EST
Update
Cloudflare is still investigating.
Posted Mar 06, 2026 - 07:07 EST
Update
We are continuing to investigate this issue.
Posted Mar 06, 2026 - 06:53 EST
Update
We are continuing to investigate this issue.
Posted Mar 06, 2026 - 06:27 EST
Investigating
We want to inform you of a connectivity issue impacting some users accessing DATABASICS services.
Cloudflare has reported increased HTTP request latency originating from some of Cloudflare data Centers. As a result, users whose traffic is routed through this location may experience:
Slower page load times Intermittent delays when submitting transactions Temporary performance degradation
Our team is actively monitoring the situation and working closely with Cloudflare to track the progress of resolution. We will provide updates as soon as performance stabilizes.
We appreciate your patience and understanding.
Posted Mar 06, 2026 - 06:27 EST
This incident affected: DATABASICS Time and Expense Website And Mobile App and Integration API and JDBC Connection.