Users unable to access mobile app on legacy devices and old Android OS

Incident Report for DATABASICS Inc

Postmortem

To resolve the issue, we collaborated closely with our SSL vendor to implement backward compatibility for legacy devices and older versions of iOS and Android. Our vendor provided a certificate that enabled these devices to successfully establish trust with the updated certificate authority, restoring secure access across platforms.

Posted Aug 26, 2025 - 08:52 EDT

Resolved

Users on legacy devices and old Android OS were unable to access mobile app after SSL certificate update on Site30
Posted Aug 23, 2025 - 08:00 EDT